Rodrigo Arias Mallo
22cc1d33f7
The database will hold the performance results of the execution of the benchmarks. We follow the same setup on knights3 for now. Reviewed-by: Aleix Roca Nonell <aleix.rocanonell@bsc.es>
20 lines
493 B
Nix
20 lines
493 B
Nix
{ lib, ... }:
|
|
|
|
{
|
|
services.postgresql = {
|
|
enable = true;
|
|
ensureDatabases = [ "perftestsdb" ];
|
|
ensureUsers = [
|
|
{ name = "anavarro"; ensureClauses.superuser = true; }
|
|
{ name = "rarias"; ensureClauses.superuser = true; }
|
|
{ name = "grafana"; }
|
|
];
|
|
authentication = ''
|
|
#type database DBuser auth-method
|
|
local perftestsdb rarias trust
|
|
local perftestsdb anavarro trust
|
|
local perftestsdb grafana trust
|
|
'';
|
|
};
|
|
}
|