Rodrigo Arias Mallo
4bd1648074
Apparently the ttyS0 console doesn't exist but ttyS1 does: raccoon% sudo stty -F /dev/ttyS0 stty: /dev/ttyS0: Input/output error raccoon% sudo stty -F /dev/ttyS1 speed 9600 baud; line = 0; -brkint -imaxbel The dmesg line agrees: 00:03: ttyS1 at I/O 0x2f8 (irq = 3, base_baud = 115200) is a 16550A The console configuration is then moved from base to xeon to allow changing it for the raccoon machine. Reviewed-by: Aleix Boné <abonerib@bsc.es>
15 lines
278 B
Nix
15 lines
278 B
Nix
{
|
|
# Restart the serial console
|
|
systemd.services."serial-getty@ttyS0" = {
|
|
enable = true;
|
|
wantedBy = [ "getty.target" ];
|
|
serviceConfig.Restart = "always";
|
|
};
|
|
|
|
# Enable serial console
|
|
boot.kernelParams = [
|
|
"console=tty1"
|
|
"console=ttyS0,115200"
|
|
];
|
|
}
|