Rodrigo Arias Mallo
604cfd90a3
The current srun version used in MN4 returns 0 if the program crashes after MPI_Finalize, as shown by this test.
21 lines
208 B
Nix
21 lines
208 B
Nix
{
|
|
stdenv
|
|
, mpi
|
|
}:
|
|
|
|
stdenv.mkDerivation {
|
|
name = "sigsegv";
|
|
|
|
src = ./.;
|
|
|
|
buildInputs = [ mpi ];
|
|
|
|
buildPhase = ''
|
|
mpicc sigsegv.c -o sigsegv
|
|
'';
|
|
|
|
installPhase = ''
|
|
cp sigsegv $out
|
|
'';
|
|
}
|